CarpForum - Fishing Forum
   [Log-In] or [Register]

Advertise to thousands of anglers a day!  Click HERE to see how
      Home            Search       Help / FAQs   Rules / Usage 
Who's Online Member List      Articles           Gallery           Weather     
  New Posts: 0
 New Posts  Fish finder signal issue
 [Log-In]  [Register]
Onlya30
Posts: 621
Onlya30
   Old Thread  #4 20 Nov 2022 at 10.16pm    Login    Register
Thanks for your suggestions. I took it back to the guy who installed it for me yesterday and he has installed a new one for me. He couldnít work out the fault either on the unit, so he is sending it back as faulty
Calabro
Posts: 334
   Old Thread  #3 18 Nov 2022 at 9.37pm    Login    Register
In reply to Post #1
Never used that , but had issues with other devices. Not a clue if it will work for you, but worth a try. Raise your receiver as high as possible (do not put on the ground). Make sure there's no signals jamming your connection (power pylons / bluetooth / wifi, etc). FIRST power your signal tower, THEN your fish finder. Make sure there's no objects between you and your boat and be sure your sensor doesn't loose contact with the water. When they do, they loose signal, only to get it back when placed in the water. Also, some units freak out on very shallow waters.

Victory
Posts: 816
Victory
   Old Thread  #2 11 Nov 2022 at 5.55pm    Login    Register
In reply to Post #1
Make sure the Ariel connector is dry and that any connections to do with the Ariel and screen are seated/connected properly.
Also reset all batterys.
And restart all software.
Good luck.
Onlya30
Posts: 621
Onlya30
   Old Thread  #1 10 Nov 2022 at 6.37pm    Login    Register
Not sure if anyone can help me at all??

Iíve got a deliverance bait boat with a lucky fish finder fitted and on my last trip the boat would go out about 10 metres but lose signal to the fish finder screen. Iíve tried everything thatís simple to check, changed batteries, ordered new aerial, checked connectors in the unit, I canít see anything obvious.

It does seem that putting the aerial on the boat, makes the signal worse?? Itís bizarre!

I must admit Iíve not got a clue what Iím doing, terrible with anything remotely electrical.

Obviously Iíll send it back but wondered if there is a quick fix I could look for and maybe try and do myself?

Cheers 👍🏻
Page: 1 of 1
   Advertising disclosure  
  © Copyright 2002-2023  -  www.CarpForum.co.uk contact : webmaster@carpforum.co.uk