CarpForum - Fishing Forum
  Already registered? [Log-In]  New user? [Register]

Want 11,000+ anglers a day to see your product or service?  Click HERE to see how
Home Who's Online Member List Gallery Downloads Fish Ins Weather
Rules / Usage Help / FAQs Search Articles The Carp Shop Fishy Forums
  New Posts: 0
   Electric Thermostatic Shower
 [Log-In]  [Register] 
Chuffy is not surfing CarpForum at the moment
View the profile of Chuffy (Rob)
Contact details supplied to MODs
Chuffy
Posts: 4176
   Old Thread  #6 8 Feb 2019 at 9.21am Login so you can post / reply  Register so you can join in!
Thanks for the replies chaps. Had the Triton engineer have a look at it and apparently itís working as it should, he tested the flow rate etc. and itís as expected. Itís just totally different to the previous non thermo one that was in there before, live and learn, at least he didnít charge me
AndyCarper82 is not surfing CarpForum at the moment
View the profile of AndyCarper82 (Andy)
AndyCarper82
Posts: 1709
   Old Thread  #5 7 Feb 2019 at 10.24pm Login so you can post / reply  Register so you can join in!
In reply to Post #1
There may be a comb filter in the water feed line, this will restrict flow. Look at the instructions to see where it is or ask the installer..?

heathrow is not surfing CarpForum at the moment
View the profile of heathrow (Heathrow)
Check out the gallery of heathrow
Contact details supplied to MODs
heathrow
Posts: 8255
   Old Thread  #4 1 Feb 2019 at 11.37pm Login so you can post / reply  Register so you can join in!
In reply to Post #1
If you read the install instructions sometimes you have to calibrate the shower as the thermostatic valve insind the shower can restrict the flow
Chuffy is not surfing CarpForum at the moment
View the profile of Chuffy (Rob)
Contact details supplied to MODs
Chuffy
Posts: 4176
   Old Thread  #3 1 Feb 2019 at 8.23pm Login so you can post / reply  Register so you can join in!
In reply to Post #2
It shows the same behaviour with the head off. The old one was 10.5kw the new one is 9.5kw.
jeffire is not surfing CarpForum at the moment
View the profile of jeffire (Jeffrey)
Contact details supplied to MODs
jeffire
Posts: 1647
   Old Thread  #2 1 Feb 2019 at 7.25pm Login so you can post / reply  Register so you can join in!
In reply to Post #1
Take the head off and run it just through the flex, refit and see what happens , is if the same power rating as your old one ?
Chuffy is not surfing CarpForum at the moment
View the profile of Chuffy (Rob)
Contact details supplied to MODs
Chuffy
Posts: 4176
   Old Thread  #1 1 Feb 2019 at 6.27pm Login so you can post / reply  Register so you can join in!
Anyone know anything about these?

I have just had a Triton Easi-Fit+ one fitted to replace an older Trtion non-thermo version.

Question is, on the old one if I put it to the full cold setting ( i.e heaters off and dial to full flow) I got massive flow rate to the point where the shower head would almost do the comedy 'hosepipe with a mind of it's own' thing.

On the new one however the behaviour is totally different. Initially when putting to cold I get more pressure but after a couple of seconds the flow rate reduces quite a bit. Is this normal for a thermostatic model in that it tries to keep a constant flow rate etc?

Just want to check if I need to phone Triton.

Page: 1 of 1  
  
  © Copyright 2002-2019  -  www.CarpForum.co.uk contact : webmaster@carpforum.co.uk